Raspberry pi streamlit

@randyzwitch the above suggests a route forward could be to split out requirements for custom components as an optional install, something like pip install streamlit[custom-components]

As of version 0.85, Arrow is no longer optional :slight_smile:

For those using this solution. The new url for wget is: https://apache.jfrog.io/artifactory/arrow/ubuntu/apache-arrow-archive-keyring-latest-focal.deb

For those who are looking for a solution, this worked for me:

How to Install Streamlit on Raspberry Pi 4 Model B (8gb)

  1. Download the latest version of Raspberry Pi OS 64-bit (raspios_arm64) from here

  2. Write the image on your SD Card

  3. Install Miniforge

$ wget https://github.com/conda-forge/miniforge/releases/latest/download/Miniforge3-Linux-aarch64.sh
$ chmod +x Miniforge3-Linux-aarch64.sh
$ ./Miniforge3-Linux-aarch64.sh
$ sudo reboot
  1. After reboot:
$ conda update conda
$ conda config --add channels conda-forge
$ conda config --set channel_priority strict
$ conda create -n streamlit
$ conda activate streamlit 
$ conda install -c conda-forge streamlit
  1. check if it works
$ streamlit hello
2 Likes

Works for me. Thanks.

2 Likes

I have to struggle with 32 bits on my raspberry pi 4 to install streamlit. After that I have installed 64 bits on my raspberry pi 4 with following system:

Ubuntu 20.04.3 LTS
Linux ubuntu-pi-cam-211121 5.4.0-1046-raspi #50-Ubuntu SMP PREEMPT Thu Oct 28 05:32:10 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

just use pip to install streamlit:
$pip install streamlit

It works fine.

1 Like

I had 32 bit OS installed on my pi, streamlit didn’t work .
But my hardware is aarch64,
So I installed a 64 bit OS and did this command-
$ sudo pip install streamlit
It worked for me :smile: :smile:.

Thanks to all…

@zhou_sean It works for me thanks.