Rename reboot to redeploy

[Clarification/feature request]

As I understand there are 3 basics steps of deployment:

  • clone repo
  • install dependencies
  • run app

Reboot is a bit misleading - it suggests the action of killing the app and running it again, so the last step only. So I propose to rename it to Redeploy, because it actually updates the repo and installs dependencies (AFAIK).

Hey @mjmikulski :wave:

First, welcome to the Streamlit community! :partying_face::partying_face::partying_face::tada::tada::tada:

Interesting suggestion! The best place for this to get seen by our engineering team is to post your idea on github!

This link will bring you to the right place:

Happy Streamlit-ing
Marisa