Resolving Dependencies on Streamlit Cloud

Trying to deploy an app. My requirements file is short:
branca==0.4.2
folium==0.11.0
geopandas==0.10.0
numpy==1.21.2
pandas==1.3.3
streamlit==1.1.0
streamlit_folium==0.4.0

However, the log can’t find dozens of dependencies. What am I missing? i’ve also tried a long requirements file but I get the same error.

== todd

[log]
client] Provisioning machine…
[client] Preparing system…
[client] Spinning up manager process…
[client] Inflating balloons…
e[32m[manager] e[0mStarting up for owner: ‘fentoad72’, repository: ‘wxwarning’, branch: ‘main’, main module: ‘wxwarning.py’
e[32m[manager] e[0mCloning repository …
e[32m[manager] e[0mCloning into ‘wxwarning’…

e[32m[manager] e[0mCloned repository!
e[32m[manager] e[0mProcessing dependencies …
Collecting package metadata (repodata.json): …working… [2021-11-07 20:21:23.160033] done
Solving environment: …working… [2021-11-07 20:21:23.398997] failed

ResolvePackageNotFound:

  • llvmlite==0.36.0=py39h798a4f4_0
  • certifi==2021.10.8=py39hecd8cb5_0
  • libutf8proc==2.6.1=h9ed2024_0
  • yaml==0.2.5=haf1e3a3_0
  • setuptools==58.2.0=py39h6e9494a_0
  • jedi==0.18.0=py39h6e9494a_2
  • hdf5==1.12.1=nompi_h2f0ef1a_100
  • libpng==1.6.37=h7cec526_2
  • libopenblas==0.3.17=openmp_h3351f45_1
  • sympy==1.8=py39h6e9494a_0
  • expat==2.4.1=he49afe7_0
  • poppler==21.09.0=h9573804_3
  • snappy==1.1.8=hb1e8313_0
  • libffi==3.4.2=he49afe7_4
  • astor==0.8.1=py39hecd8cb5_0
  • re2==2021.09.01=he49afe7_0
  • libiconv==1.16=haf1e3a3_0
  • pytest==6.2.5=py39h6e9494a_0
  • debugpy==1.4.1=py39h9fcab8e_0
  • pyzmq==22.3.0=py39h7fec2f1_0
  • libedit==3.1.20191231=h0678c8f_2
  • proj==8.1.1=h1512c50_2
  • coverage==6.0=py39h89e85a6_1
  • pysocks==1.7.1=py39h6e9494a_3
  • nbconvert==6.2.0=py39h6e9494a_0
  • libpq==13.3=hea3049e_0
  • pcre==8.45=he49afe7_0
  • python==3.9.7=h1248fe1_3_cpython
  • blosc==1.21.0=he49afe7_0
  • brotlipy==0.7.0=py39h89e85a6_1001
  • libbrotlienc==1.0.9=h0d85af4_5
  • boost-cpp==1.74.0=hff03dee_4
  • abseil-cpp==20210324.2=h23ab428_0
  • lz4-c==1.9.3=he49afe7_1
  • postgresql==13.3=he8fe76e_0
  • freexl==1.0.6=h0d85af4_0
  • widgetsnbextension==3.5.1=py39h6e9494a_4
  • libnghttp2==1.43.0=h6f36284_1
  • pillow==8.3.2=py39he9bb72f_0
  • libev==4.33=haf1e3a3_1
  • libzlib==1.2.11=h9173be1_1013
  • argon2-cffi==20.1.0=py39h89e85a6_2
  • cryptography==3.4.7=py39ha2c9959_0
  • icu==68.1=h74dc148_0
  • libprotobuf==3.18.1=hcf210ce_0
  • glog==0.5.0=h23ab428_0
  • cfitsio==3.470=h01dc385_7
  • scikit-learn==1.0=py39hd2caeff_1
  • liblapack==3.9.0=11_osx64_openblas
  • openssl==1.1.1l=h9ed2024_0
  • libcblas==3.9.0=11_osx64_openblas
  • ca-certificates==2021.10.26=hecd8cb5_2
  • libbrotlicommon==1.0.9=h0d85af4_5
  • libzip==1.8.0=h8b0c345_1
  • pyarrow==5.0.0=py39hc3b5b9c_8_cpu
  • zstd==1.5.0=h582d3a0_0
  • jupyter_core==4.8.1=py39h6e9494a_0
  • libevent==2.1.8=hddc9c9b_1
  • pixman==0.40.0=hbcb3906_0
  • fontconfig==2.13.1=h10f422b_1005
  • mock==4.0.3=py39h6e9494a_1
  • libxml2==2.9.12=h93ec3fd_0
  • giflib==5.2.1=hbcb3906_2
  • ncurses==6.2=h2e338ed_4
  • numba==0.53.1=py39h32e38f5_1
  • libgfortran==5.0.0=9_3_0_h6c81a4c_23
  • pulp==2.5.0=py39h6e9494a_0
  • pygeos==0.10.2=py39h1d9c377_0
  • hdf4==4.2.15=hefd3b78_3
  • aws-sdk-cpp==1.8.186=h766a74d_3
  • lerc==2.2.1=h046ec9c_0
  • c-ares==1.17.2=h0d85af4_0
  • pandoc==2.14.2=h0d85af4_0
  • numexpr==2.7.3=py39h4d6be9b_0
  • sqlite==3.36.0=h23a322b_2
  • tzlocal==2.1=py39hecd8cb5_0
  • lcms2==2.12=h577c468_0
  • matplotlib==3.4.3=py39h6e9494a_1
  • llvm-openmp==12.0.1=hda6cdc1_1
  • libnetcdf==4.8.1=nompi_h6609ca0_101
  • pyproj==3.2.1=py39h5ea97c7_2
  • libglib==2.68.4=hf1fb8c0_1
  • blinker==1.4=py39hecd8cb5_0
  • argh==0.26.2=py39hecd8cb5_0
  • statsmodels==0.13.0=py39hc89836e_0
  • gdal==3.3.2=py39h9e6e899_4
  • anyio==3.3.2=py39h6e9494a_0
  • websocket-client==0.57.0=py39h6e9494a_4
  • wget==1.20.1=h051b688_0
  • jbig==2.1=h0d85af4_2003
  • libssh2==1.10.0=h52ee1ee_2
  • libspatialindex==1.9.3=he49afe7_4
  • libgfortran5==9.3.0=h6c81a4c_23
  • pytables==3.6.1=py39hfd850c7_4
  • geotiff==1.7.0=hb0faedc_3
  • libdap4==3.20.6=h3e144a0_2
  • json-c==0.15=hcb556a6_0
  • mistune==0.8.4=py39h89e85a6_1004
  • aws-c-event-stream==0.2.7=hb9330a7_13
  • openjpeg==2.4.0=h6e7aa92_1
  • aws-c-common==0.6.2=h0d85af4_0
  • mpfr==4.1.0=h0f52abe_1
  • librttopo==1.1.0=h5413771_6
  • pyyaml==5.4.1=py39h89e85a6_1
  • numpy==1.21.2=py39h7eed0ac_0
  • libgdal==3.3.2=h053b6da_4
  • docutils==0.17.1=py39h6e9494a_0
  • gflags==2.2.2=h0a44026_0
  • pluggy==1.0.0=py39h6e9494a_1
  • shapely==1.7.1=py39h1d9c377_5
  • watchdog==2.1.3=py39hd5f6b7e_0
  • cairo==1.16.0=he43a7df_1008
  • zeromq==4.3.4=he49afe7_1
  • freetype==2.10.4=h4cff582_1
  • zlib==1.2.11=h9173be1_1013
  • cffi==1.14.6=py39he338e87_1
  • importlib-metadata==4.8.1=py39h6e9494a_0
  • aws-checksums==0.1.11=h0010a65_7
  • rvlib==0.0.5=py39hc89836e_0
  • libdeflate==1.7=h35c211d_5
  • rasterio==1.2.9=py39hf4c83f0_2
  • pyrsistent==0.17.3=py39h89e85a6_2
  • mpc==1.2.1=hbb51d92_0
  • markupsafe==2.0.1=py39h89e85a6_0
  • quantecon==0.5.1=py39h6e9494a_0
  • libtiff==4.3.0=h1167814_1
  • kealib==1.4.14=ha22a8b1_3
  • notebook==6.4.3=py39hecd8cb5_0
  • libllvm10==10.0.1=h009f743_3
  • libwebp-base==1.2.1=h0d85af4_0
  • scipy==1.7.1=py39h056f1c0_0
  • krb5==1.19.2=hcfbf3a7_2
  • orc==1.7.0=hf163092_0
  • pandas==1.3.3=py39h4d6be9b_0
  • ipython==7.28.0=py39h71a6800_0
  • libcurl==7.79.1=hf45b732_1
  • rtree==0.9.7=py39h7d0d40a_2
  • libthrift==0.15.0=h054ceb0_0
  • kiwisolver==1.3.2=py39hf018cea_0
  • libcxx==12.0.1=habf9029_0
  • libkml==1.3.0=h8fd9edb_1014
  • selenium==3.141.0=py39h9ed2024_1000
  • nss==3.69=h31e2bf1_1
  • xerces-c==3.2.3=h379762d_2
  • tornado==6.1=py39h89e85a6_1
  • matplotlib-base==3.4.3=py39hb07454d_1
  • libspatialite==5.0.1=hfc891e7_9
  • tiledb==2.3.4=h8370e7a_0
  • fiona==1.8.20=py39h10412eb_1
  • readline==8.1=h05e3726_0
  • geos==3.9.1=he49afe7_2
  • arrow-cpp==5.0.0=py39h7fc7d4f_8_cpu
  • simplejson==3.17.5=py39h89e85a6_0
  • coincbc==2.10.5=h35dd71c_1
  • libblas==3.9.0=11_osx64_openblas
  • tzcode==2021c=h0d85af4_0
  • xz==5.2.5=haf1e3a3_1
  • nspr==4.30=hcd9eead_0
  • bzip2==1.0.8=h0d85af4_4
  • gmpy2==2.1.0b5=py39hab8a6df_0
  • libbrotlidec==1.0.9=h0d85af4_5
  • curl==7.79.1=hf45b732_1
  • gettext==0.19.8.1=hd1a6beb_1008
  • aws-c-io==0.10.5=h35aa462_0
  • tk==8.6.11=h5dbffcc_1
  • appnope==0.1.2=py39h6e9494a_1
  • ipykernel==6.4.1=py39h71a6800_0
  • gmp==6.2.1=h2e338ed_0
  • sniffio==1.2.0=py39h6e9494a_1
  • chardet==4.0.0=py39h6e9494a_1
  • jpeg==9d=hbcb3906_0
  • terminado==0.12.1=py39h6e9494a_0
  • aws-c-cal==0.5.11=hd2e2f4b_0
  • libsodium==1.0.18=hbcb3906_1
  • grpc-cpp==1.40.0=h8fdf118_2

e[32m[manager] e[0minstaller returned a non-zero exit code
e[32m[manager] e[0mError during processing dependencies! Please fix the error and push an update, or try restarting the app.

I realized the problem was I had an environment.yml file and streamlit was trying to use both requirements.txt and environment.yml. I removed the yml file and the app loaded.