Streamlit Cloud down?

This app ( was working just fine yesterday. Nothing changed but now I’m getting this error:

[11:04:37] :octopus: Failed to download the sources for repository: ‘final-project’, branch: ‘master’, main module: ‘package/’

Github link to the project: final-project/package/ at master · Bketting/final-project · GitHub

Hi @Bketting :wave:

Thanks for letting us know, and sorry to hear your app is down—the app sounds super cool, by the way!

It looks like the Streamlit Community Cloud isn’t down across the board – I’ve checked out a few other apps, and they’re up and running smoothly.

Could you give removing and redeploying your app a shot? It might just do the trick. But if it doesn’t, let me know and we’ll dig deeper into this.

Best wishes,

Thanks for replying so quickly (and the compliment) Charly. I tried redeploying the app a few times with no success (unfortunately). I haven’t changed anything to the app since the last time it worked.

1 Like

You’re welcome :slight_smile:

I assume you did a full redeployment - deleting the app and redeploying from scratch, rather than a simple reboot, is that right?

Best wishes,

Yes that is correct. Maybe interesting to know that the below also doesn’t work anymore. I now have to paste the full GH path.

Can you deploy when pasting the full GH path?

I can but then I get this:

[13:10:04] 🖥 Provisioning machine...
[13:10:04] 🎛 Preparing system...
[13:10:04] ⛓ Spinning up manager process...
[13:10:11] 🚀 Starting up repository: 'final-project', branch: 'master', main module: 'package/'
[13:10:11] 🐙 Cloning repository...
[13:10:17] 🐙 failed
[13:10:36] 🐙 failed
[13:10:52] 🐙 failed
[13:11:24] 🐙 failed
[13:11:41] 🐙 failed
[13:11:51] 🐙 Failed to download the sources for repository: 'final-project', branch: 'master', main module: 'package/'
[13:11:51] 🐙 Make sure the repository and the branch exist and you have write access to it, and then reboot the app.
[13:13:22] ❗️ Streamlit server consistently failed status checks
[13:13:22] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

Thanks for sending this, @Bketting. I’m not too familiar with this error, besides I haven’t been hands-on with Streamlit Community Cloud issues recently. @tonykip, is it something you may be familiar with by any chance?


Thanks for the tag @Charly_Wargnier. @Bketting, is this the app in question?
Just want to confirm before digging into the logs.

Yes it is!

HI! The problem is that the repository from which the application was deployed is empty Bketting/final-project · GitHub , so the error message is valid.

I’m reuploading it today but didn’t have enough time to finish before leaving the house. This is not the cause of the error.

I found a related topic in which exceeding the LFS quota (which I also did) was indicated as the problem.

Update: the above was indeed the error! Resolving it fixed the issues.

Glad to hear it’s now fixed, @Bketting.

Thanks, @Alexandru_Toader and @tonykip, for the support :pray:


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.