Streamlit deployment error during processing dependencies


This is my first time deploying the app through streamlit.
I have put the packages that I want to import to requirements.txt as the following.

However, everytime I run the app, I am getting the following error and not sure how to fix it. Could anyone give me help? Thank you in advance!

Hi @barky

Lines 1-8 should work perfectly as is. However the problem lies in lines 9-12. For lines 9 and 10, youโ€™ll need to delete the empty spaces so that it becomes torch==1.9.0 and torchvision==0.10.0.

As for installing from GitHub, you can refer to the following:

Hope this helps!

1 Like

Thank you for your help!
I stopped getting such error message after fixing the requirements.txt like this.

However, now I am facing with another solution which is telling me that there is no module named torch. Iโ€™ve tried to look for a solution in the community to solve this problem, but is still running to error. Would there be any reasons why this is happening?