Streamlit doesnot launch app, and keeps showing please wait in chrome


Streamlit shows please wait page foreever. However, streamlit v 1.0.0. is working without any issues. I could not find a good solution to this issue. I want to use the multipage functionality in the newer version. But, the newer version is not launching my app!!! Tried all the steps in App is not loading when running remotely - Streamlit Docs.
Where do you change these setting browser.serverport?
The below given is a line from the helper link
If this fixes your issue, you should re-enable CORS protection and then set browser.serverPort and browser.serverAddress to the URL and port of your Streamlit app.

Can you provide a bit more detail about the environment in which you are trying to deploy? The issue you described is very environment-specific.

I am getting the same error. I am using it in Jupyter. I have tried many methods but I still didn’t get the solution.

I used streamlit v 1.11.0.and it worked for me in my ubuntu 22.04 LTS
All other versions are giving the same error.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.