[Streamlit Error] Error installing requirements

Hi

I suddenly encountered the error message that ‘Erro Installing Requirements’ so I was trying to search it in the community and have done most of the guidance. I think it’s a something matter of dependency in package.txt file , but no idea which part of it is really matter.

Please guide me to go to the right direction.
Streamlit version: 1.2.0
Anaconda Navigator: 2.1.1

my packages.txt
freeglut3-dev
libgtk2.0-dev
libgl1-mesa-glx
tesseract-ocr
libtesseract-dev
libtesseract4
tesseract-ocr-all

requirements.txt
streamlit==0.79.0
opencv-python-headless==4.5.1.48
textblob==0.15.3
scipy==1.6.1
numpy==1.19.2
pytesseract==0.3.7
nltk==3.5
pandas==1.2.2
scikit-learn==0.24.2
pyspellchecker
Inflect
flask
flask_cors
pip

Hi @djshan1979,

I don’t see any obvious mistakes in either of the files. In fact, I was able to fork your repo that had the exact same dependency files and successfully deploy the app.

Have you tried rebooting the app and/or deleting it and redeploying?

Hi thanks for getting back to me.
I did rebooting but it was not working.
Didnt try to delete and redeploying yet.

Will try and let you know later.
Cheers

Brian