Streamlit generated URLs doesnt work


Streamlit generated URLs doesnt work

Steps to reproduce

Code snippet:

pip install streamlit
import streamlit as st
import yfinance as yf

st.title("Stocks App")
symbol = st.text_input("Enter a stock symbol", "AAPL")
if st.button("Get Quote"):

!npm install localtunnel

!tunnel lt --port 8080 --subdomain pcdemo
!streamlit run & npx localtunnel --port 8080


2023-05-23 02:12:54.981 INFO    numexpr.utils: NumExpr defaulting to 2 threads.
[##................] - fetchMetadata: sill resolveWithNewModule is-fullwidth-co
Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.

  You can now view your Streamlit app in your browser.

  Network URL:
  External URL:

npx: installed 22 in 2.259s
your url is:```

If applicable, please provide the steps we should take to reproduce the error or specified behavior.

**Expected behavior:**

The app should start

**Actual behavior:**

URLs not opening , getting not found

### Debug info

- Streamlit version: (get it with `$ streamlit version`)  - 1.13
- Python version: (get it with `$ python --version`) - 3.10
- Using Conda? PipEnv? PyEnv? Pex? Tried with Jupyter notebook and google colab same error
- OS version: Windows 11
- Browser version: Edge version 113.0.1774.50 

### Requirements file

Using Conda? PipEnv? PyEnv? Pex? Share the contents of your requirements file here.
Not sure what a requirements file is? Check out [this doc]( and add a requirements file to your app.

### Links

* Link to your GitHub repo:
* Link to your deployed app:

### Additional information

If needed, add any other context about the problem here.

Hey @Deepa_Nair,

Which URL isn’t working for you?