Streamlit on Apple M1

Has anyone tried out Streamlit on an Apple M1? How has your experience been? I’ve been running into some installation issues, trying to figure out if it’s actually M1 centered issues or if it is just my very rudimentary knowledge of python package installation and management.

It appears that trying to install Python via homebrew wasn’t the most friendly way to go about things. After using Anaconda and the typical pip install streamlit, it runs just fine on the M1.

3 Likes

Thanks for letting us know @theimposingdwarf! I suspect what you are running into is the common update cycle in that it’s going to take a while for the new architecture to work its way through all the myriad ways to install Python

Battling with this now. Running streamlit in a python venv is ok, but on docker getting strange errors from watchdog, OSError: [Errno 38] Function not implemented

Same here with robmarkcole. Library “click” may be involved in that error.

Just so I’m understanding, which one is having the issue? @theimposingdwarf was having issues with Python via homebrew, but Anaconda seems okay. Is it venv that you’re having trouble with?

on docker, via pip

Since you and @robmarkcole are having trouble with Docker only, and venv seems to be working, I’m inclined to say that its Docker for Mac that has an issue. I don’t follow that very closely, but maybe Docker is misrepresenting the underlying architecture to still be Intel?

Either way, I don’t have a good answer to suggest, sorry.

Here’s where I’ve landed – GitHub - jroes/streamlit-getting-started-m1: Instantly-working M1-native Streamlit development environment using VSCode, Docker, and Conda.. Inside is a Docker image you could pull from if you’re not a VSCode user.

1 Like

I managed to install streamlit on a MacBook Air M1 today.
No Anaconda, no minconda, just plain old python.
I tried 1-2 months back it did not work.

Python version: 3.9.5 (from python.org)
Streamlit version: 0.83.0

Just thought I would share that with you.

2 Likes

Im also not experiencing any issues on streamlit==0.84.0 :slight_smile:

1 Like

I am having the same issue. I am new on streamlit, I am pip installing on Mac, this what i

there errors are just long, this is just the top two screenshots I could take, hopefully it makes sense. thanks.

So I installed xcode and the xcrun error is solved. now I have this error left:
error: command ‘/Users/runner/miniforge3/conda-bld/python-split_1608587737618/_build_env/bin/llvm-ar’ failed: No such file or directory

when I try to pip install streamlit, thats the error I get now. any pointers?

1 Like

are you having the error when trying to install pandas==1.2.5 ?
I tried pip install pandas 1.2.5 over my M1 machine and it didn’t work although the 1.3.0 version works fine. Is there a way to actually install Streamlit with the new version of Pandas from the command line?