Streamlit on Azure: Webapp stuck at "Please wait ..."

We are deploying a streamlit webapp on Azure, and getting a perpetual “Please wait” message on the webpage.

This web application is working fine on a local computer with localhost. The application is also getting built successfully on Azure container deployment. However, when we open the URL, we see a please wait error message.

We attempted to follow instructions in this streamlit knowledge-base document to resolve the issue, but the advise hasn’t worked. This included …

  • Changing port numbers.
  • Flipping ‘server.enableCORS’ from true to false in config.toml file.
  • Changing ‘server.enableWebsocketCompression’ from true to false in config.toml as well.
  • Checking to ensure we have a valid SSL certificate.

We also attempted streamlit package update to latest version, but the effect was worse (streamlit failed to launch with an error message telling us to look at diagnostics, which we couldn’t find easily).

We noticed that in developer tools in chrome that “stream” websocket type perpetually says “Pending”.

Is there a log file where we can see what is the reason streamlit is stuck at Please Wait? Any other suggestions to try?

hey @guhaamitava, what is the python version that you’re using?

Python version 3.7-slim

I talked to @jrieke and he mentioned having a similar problem, he said that upgrading to 3.9.12 helped him out

I just upgraded to version 3.9.1 and mine worked too. :partying_face:

2 Likes

awesome!! shoutout to @jrieke then :slight_smile:

1 Like