Streamlit support for Qiskit?

Our error seems to be simple. When we load our application server side on the streamlit platform, it does not download Qiskit for some reason as a library or dep. Any reasons Qiskit and running simulated quantum circuits is not supported on the cloud platform? We can run it locally on Nvidia Jetson family arm64 architecture, Ubuntu 18.04, Pytorch 1.8.0, and Cuda 10.2. PyCUDA is a different topic and animal.

May be if it involves any apt-get dependencies then place them in packages.txt and check?
Like if any python lib you are using involves some local CLI tools then you need to install them too

Thank you. Will try this and circle back.

I created the requirements.txt file. It still wouldn’t take. We will continue to run the stack locally. We appreciate your time. Thank you.

tried installing required packages?
using packages.txt

Yes, it will not load qiskit, even with the packages.txt file included with qiskit as a dep. Could you try to load a packages file with qiskit as a module, to replicate?

I am having a hard time trying to understand what you mean by this. Are you seeing any error messages?

quiskit is a python package and you need it in requirements.txt, not packages.txt.

You are correct. We can close this. Issue solved. Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.