Stuck in the Oven unable to know the issue

My app stuck in the oven for so long
Github repo https://github.com/Sudhakar123456789/project

Hi @psr, welcome to the Streamlit community!

I made a fork and launched from my account, and this error message is in the logs:

[client] Provisioning machine...

[client] Preparing system...

[client] Spinning up manager process...

[client] Inflating balloons...

[manager] Starting up repository: 'project', branch: 'main', main module: 'chatbotproject.py'

[manager] Cloning repository...

[manager] Cloning into '/app/project'...

[manager] Cloned repository!

[manager] Pulling code changes from Github...

[manager] Processing dependencies...

Hit:1 http://deb.debian.org/debian bullseye InRelease

Get:2 http://deb.debian.org/debian bullseye-updates InRelease [39.4 kB]

Get:3 http://security.debian.org/debian-security bullseye-security InRelease [44.1 kB]

Get:4 https://packages.microsoft.com/debian/10/prod buster InRelease [29.8 kB]

Get:5 http://security.debian.org/debian-security bullseye-security/main amd64 Packages [116 kB]

Get:6 https://packages.microsoft.com/debian/10/prod buster/main amd64 Packages [140 kB]

Fetched 369 kB in 1s (564 kB/s)

Reading package lists...[2022-02-04 19:46:47.556158] 

Building dependency tree...[2022-02-04 19:46:47.745503] 

Reading state information...[2022-02-04 19:46:47.745830] 

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

 libodbc1 : PreDepends: multiarch-support but it is not installable

 odbcinst1debian2 : PreDepends: multiarch-support but it is not installable

E: Unable to correct problems, you have held broken packages.

[manager] installer returned a non-zero exit code

[manager] Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

It appears that your packages.txt file does not contain all of the required dependencies to build your app.

Best,
Randy

@randyzwitch This is the error I am getting now.

@psr I had a similar issue that another module I was using was not found. The fix for me was to just update streamlit from version 1.3.1 to 1.5.0 but I am not sure why this fixed the issue.

Also locally everything worked fine for me even with version 1.3.1, is that also the case for you?

@psr are you still encountering this issue? Could you share a link to your repository so that we can try to fix the problem?

@Alex_Toader It is solved now.

1 Like