Stuck on "Your app is in the oven"

Hey everyone! I just deployed a new app ( on the streamlit cloud from my github repo. Seemed like all the python libraries loading correctly, and it’s working on my localhost. Just wondering why the deployment has been stuck on “Your app is in the oven” for a couple hours now.

Looking at older posts of this sort, it seemed like they just had to reach out here and people on the streamlit team updated something in the backend to have it fixed? Either way, thank you for your time!!

Is the app public or private? I got the error that is doesn’t exist or I don’t have permission. If it was public and still spinning up, I think I’d be able to see the “in-the-oven” message. The first build of an app can indeed take a little while, especially if you have large or complicated dependencies.

If it is still stuck in the oven 4+ hours later, I’d want to know what the log says. The screenshot posted doesn’t indicate an error was hit yet. Have you tried rebooting it?

Hey, I really appreciate the quick reply!! Yeah the app is private. If it’ll help, I can make it public or invite you by email? Either way, I’ll look at it again after 4+ hours and let you know if the logs change or if it works then. Thanks again!

I meant if it’s already been 4+ hours, I’d probably just click reboot at this point and confirm the logs… :slight_smile:

That worked! Good ol’ turn off and on again :sweat_smile: thanks a ton, @mathcatsand!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.