Transformers module not found

hi there I’m new to coding in general, I am trying to create an app that can translate words into different languages using transformers I found solutions that require requirement.txt file but there are different errors at each stage.

without requirement.txt file (just the app.py file)


with the requirement.txt and cache.py file:

github url: GitHub - sapdream/nlptranslatingapp
logs: logs - Pastebin.com

Hi @Sonny_En

From the provided log file, there also seems to be a missing dependency namely sentencepiece. Could you add that to your requirements.txt file?

Hope this helps!

thank you for the reply! But now there is a different error however it says something about tensorflow does that need to be in the requirements file as well? I tried both tensorflow and pytorch but the error is still the same, is there another name to download them by?

Hi @Sonny_En

Yes from the log it does mention that you’re missing either tensorflow or pytorch so you can add those in the requirements.txt file