Trouble with aggrid - aggrid_interactive_table

Hi,
I am trying to set an app on streamlit cloud using AgGrid.
At the beginning I can “play” with the table on the dashboard, but after “playing” with it, it seems to freeze the app, no error message is thrown and I cannot use the other function on the dashboard afterwards.

  • streamlit version : 1.14.0
  • streamlit-aggrid : 0.3.2
  • python 3.7

I guess the problem is from this aggrid command :
selection = AgGrid(df, enable_enterprise_modules=True, gridOptions=options.build(), theme="light", update_mode=GridUpdateMode.MODEL_CHANGED, allow_unsafe_jscode=True, )

I have to say that it works when I run the app locally (means not on streamlit cloud).
Here is the app : https://py53-projet7-dashboard-z498gi.streamlit.app/
And the github repository : GitHub - PY53/Projet7: Failure risk estimation for loan delivery
Please If you have already experienced such a behavior or if you have some tips to help me for finding a solution it would be much appreciated.
Thanks in advance
PS: another strange behavior is that I cannot always get my log messages on the side panel, even though I put sys.stdout.flush() in my dashboard file.

I am not able to get to your app. I get a message that I don’t have access. Is it set to public?

I don’t if I can be much help, but the first thing I was going to look at is if anything could be eating up all the memory. That’s the one thing I’ve come across with “no error” crashing/freezing type problems is just not enough memory as implemented.

ok thanks,
yes, the app access is public. I set it just after sending the first message, maybe you were quicker than me.
I had a look at the memory (running in local with psrecord), but it doesn’t looks like a memory leak or something like this.
plot

1 Like

I continue to digg into this issue.
I can see in the firefox console, this error.


I have seen some issues similar to mine related to a timeout of the component, so I have to say that my internet connexion is not very good, could it be the source of the problem. I don’t have access to a good connexion to test yet…

1 Like

I was able to get to your app this time, but it did not freeze for me. I tried to click around a bunch, mess with the dataframe, change the parameters, but it kept loading fine for me. So good news, I guess? :slight_smile:

1 Like

Thanks for your help.
I guess I will have to find a better connexion to test it.

I confirm, that it was a low broadband connexion issue

1 Like