Unable to access deployed Streamlit app


I created and deployed my Streamlit app (on the Streamlit cloud) about three months ago, and everything worked pretty well, as I visited the app regularly to prevent it from going to sleep. However, after not visiting the app for the past week, it went to sleep and I am now unable to make work again.

I have attempted to access the app on three different browsers, tried rebooting the app, made new pushes to the repository, cleared my browser’s cache, and even restarted the computer, but to no avail.

As this appears to be related to the Streamlit cloud, I would to know how I can fix this issue.

Complete log message (When I try to reboot the app)

[     UTC     ] Logs for fipran.streamlit.app/


[10:08:08] 🖥 Provisioning machine...

[10:08:15] 🎛 Preparing system...

[10:08:20] ⛓ Spinning up manager process...

[10:08:25] 🎈 Inflating balloons...

[10:08:30] 📖 Unpacking Comic Sans RAR files...

[10:08:36] 🚧 Loading "Under construction" GIF...

[10:08:41] 🛠 Compiling <blink> tags...

[10:08:46] 📠 Initializing Java applet...

[10:08:51] ⏳ Please wait...

[10:08:57] 🚀 Starting up repository: 'fipran', branch: 'main', main module: 'main.py'

[10:08:57] 🐙 Cloning repository...

[10:09:14] 🐙 failed

[10:09:43] 🐙 failed

[10:10:17] 🐙 failed

[10:10:48] 🐙 failed

[10:11:16] 🐙 failed

[10:11:26] 🐙 Failed to download the sources for repository: 'fipran', branch: 'main', main module: 'main.py'

[10:11:26] 🐙 Make sure the repository and the branch exist and you have write access to it, and then reboot the app.

[10:12:57] ❗️ Streamlit server consistently failed status checks

[10:12:57] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

Steps to reproduce

Expected behavior: (When ran locally)

This is how the app used to run before.

Actual behavior: (Deployed version)

This is what I get now after six days of inactivity.

Debug info

  • Streamlit version: 0.3.2
  • Python version: 3.11.1
  • OS version: Windows 10

Requirements file



Additional information

Not sure whether these will be useful or not.

GitHub Repo

Streamlit cloud

With a private repo, unfortunately, one can only guess. I suspect that the bandwidth quota of Git-LFS has been exceeded.

It seems like your Streamlit app went to sleep after a period of inactivity, and now you’re facing issues restarting it. You’ve tried various troubleshooting steps, including clearing caches and restarting your computer, but the issue persists.

The error message you provided suggests that there might be an issue with cloning the repository in the Streamlit cloud environment. It could be related to access permissions or Git-LFS bandwidth limits.

Since your repository is private, it’s a bit challenging to diagnose the exact problem. However, considering the Git-LFS bandwidth quota, you might want to check if you’ve exceeded those limits. If that’s the case, you may need to free up some bandwidth or consider upgrading your Git-LFS plan.

If the issue persists, reaching out to Streamlit support team so that they can provide more specific assistance based on your private repository setup.

Good luck with resolving the issue and getting your Streamlit app back up and running!

Not sure if you updated the project or fixed the issue but it works at the current moment:

Hey @IndigoWizard!

Yes, I did update the project, and the issue was indeed related to Git LFS tracked files as suggested by @Franky1 and @Ridaone. I was so relieved that I forgot to mark the issue as resolved. I spent the whole day trying all sorts of sorcery to solve it :sweat_smile:.

Thank you very much for your help guys!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.