Unable to launch app on Streamlit Cloud: Stuck at "Spinning up manager process..."

Hi, my app is running fine on my local computer but it is unable to deploy on streamlit cloud as it is stuck at “Your app is in the oven”. How do i solve this?


Maybe technical issues? I had the same problem a couple of hours ago. To test it i created a simple 2-line button click script and deployed it as a new app, and even that is getting stuck in the oven.

I have same problem

Same issue for me as well.

[09:46:25] 🐍 Python dependencies were installed from /app/datastudio_to_png/requirements.txt using pip.

Check if streamlit is installed

Streamlit is already installed

[09:46:26] 📦 Processed dependencies!

Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.

[10:59:45] 🎛 Preparing system...

[10:59:45] ⛓ Spinning up manager process...

Same issue here. Thought it was because I had introduced changes but did a rollback to the last working version and also got stuck. Is it an issue with the servers? I did get the protobuff install error as well but as I said, I did a rollback to a version that worked on cloud

Same issue here.

Hi! Are you still facing this issue? Could you provide a link to an app that is still stuck?

1 Like

@ilcarbo the issue should be resolved. Could you confirm?

yes! it’s working now
thanks :slight_smile:

@tarmojuristo did you find the root cause? We do not see any obvious issues from our side.

it was stuck for about 15 minutes and then when I checked back later, everything worked ¯_(ツ)_/¯