Whisper and Streamlit Share

Hi, have anyone developed a streamlit app using whisper ai

Im having trouble with the integration of whisper in streamlit share :(.

My code runs good in local host but when I try it streamlitshare it doesnt work.

It seems that whisper module is importing correctly but it trows me the error:

File “/mount/src/balu_app/Baluaiapp.py”, line 25, in

model = whisper.load_model("small")

AttributeError: module ‘whisper’ has no attribute ‘load_model’

sames happens when I use Language=“es” later.

Any lights on how to fix this? :pray:

It looks like you might be installing two different whisper libraries through your requirements.txt, both openai whisper from github, and whisper

The second one likely installs this whisper · PyPI which overwrites the openai one.

If you replace both lines with

openai-whisper

I think this will resolve it

Hi, thank you so much for your response!

I tried more than one instance of whisper in requirements out of desesperation :sweat_smile:

Ive updated my requirements to only have openai-whisper and im still having the same issue:

File “/mount/src/balu_app/Baluaiapp.py”, line 25, in
model = whisper.load_model(“small”)

I really dont know what might be causing trouble, I only have a few lines of codes but it seems that whisper is not recognizing the functions.

Are you sure it’s the exact same error as before? Could you paste the full text of the error from the logs?