Openai-whisper requirement is not getting installed

I am running a streamlit app but it is not installing one requirement which is openai-whisper… Please help me how to install it. Because of it my app is not running…

The easiest way of installing python packages in Streamlit Cloud is having a requirements.txt file, as explained in the documentation linked below.

Note that you may need to reboot or even redeploy your application after creating or changing requirements.txt.

If you have already done that and it didn’t work, you need to figure out what went wrong. Search the logs for messages related to the installation of openai-whisper.

Yes, I have created reuirements.txt file in the github repository but the streamlit cloud is giving error that it can not install openai-whisper. and if I only install whisper then it runs the app but when I try to use the app it gives error that whisper has no load_model module.

Wait, I am confused now. Can you get openai-whisper installed or not?

No, its not get installed because the app is giving error that module ‘whisper’ has no attribute ‘load_model’

I understand now.

There should be also some useful details about why that happens.

I am getting the following error:
SystemError: This app has encountered an error. The original error message is redacted to prevent data leaks. Full error details have been recorded in the logs (if you’re on Streamlit Cloud, click on ‘Manage app’ in the lower right of your app).


File "/home/adminuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/", line 552, in _run_script
    exec(code, module.__dict__)File "/mount/src/questibot/pages/5_QA_on_Video 🎬.py", line 12, in <module>
    import whisper,osFile "/home/adminuser/venv/lib/python3.9/site-packages/whisper/", line 13, in <module>
    from .model import ModelDimensions, WhisperFile "/home/adminuser/venv/lib/python3.9/site-packages/whisper/", line 13, in <module>
    from .transcribe import transcribe as transcribe_functionFile "/home/adminuser/venv/lib/python3.9/site-packages/whisper/", line 20, in <module>
    from .timing import add_word_timestampsFile "/home/adminuser/venv/lib/python3.9/site-packages/whisper/", line 6, in <module>
    import numbaFile "/home/adminuser/venv/lib/python3.9/site-packages/numba/", line 43, in <module>
    from import (vectorize, guvectorize, threading_layer,File "/home/adminuser/venv/lib/python3.9/site-packages/numba/np/ufunc/", line 3, in <module>
    from import Vectorize, GUVectorize, vectorize, guvectorizeFile "/home/adminuser/venv/lib/python3.9/site-packages/numba/np/ufunc/", line 3, in <module>
    from import _internal

Can you please guide me to resolve this error?

Thanks for your support… the issue is resolved in one app but there is another issue in other app… the error is as under:
Error: e[91mYour system has an unsupported version of sqlite3. Chroma requires sqlite3 >= 3.35.0.e[0m e[94mPlease visit 🔍 Troubleshooting | Chroma to learn how to upgrade.e[0m

Please guide me to resolve this issue…

Did you visit the link suggested in the error message?

Yes I have visited the link and it is mentioned there to install pysqlite3-binary library… i have put this library in my requirements.txt and reboot the app but it is still giving me the same error…

I think you should rather undo that changes and try the first suggestion instead. It looks way easier. Unless you have a good reason to skip it.

I have tried it and all the options but the app is still giving me the same error. :unamused:

can u please guide me with this issue…

I did some testing. Changing the version of python doesn’t work in Streamlit Coud because the system sqite is used anyway. Using pysqlite3-binary worked, though.

You said:

You didn’t mention this part in the troubleshooting page:

[…] override the default sqlite3 library before running Chroma with the steps here

Maybe you missed it?

Please share your public github repo link, otherwise we are keep on poking around in the dark…

Am I suppose to create file in my project’s github repo.

This post was flagged by the community and is temporarily hidden.

Regarding your requirements.txt file:

  1. Remove everything you don’t actually use in your application
  2. Use openai-whisper instead of openai

I have removed chromadb from requirements.txt and I didn’t use it in my project but it started giving me error that chromadb is not installed… and i have used both openai and openai-whisper.