All Apps are down?

Is it just me or are the most streamlit apps in the cloud down? I also tried the offical apps released by streamlit with edge and firefox but just got the please wait…

One app was loading but showd this error:
Network issue:

Cannot load Streamlit frontend code. This can happen when you update Streamlit while a Streamlit app is running.
To fix this, simply reload this app by pressing F5, Ctrl+R, or Cmd+R.
If the error persists, try force-clearing your browser’s cache as described here

1 Like

Hi, I am able to load a streamlit cloud app.

I got this issue with all my Apps and also Apps from other persons (tried with Firefox and Edge)
The console log (in german) basically says there is an connection error:

Firefox kann keine Verbindung zu dem Server unter wss:// aufbauen. main.3c7e5310.chunk.js:1:115797

Die Verbindung zu wss:// wurde unterbrochen, während die Seite geladen wurde. main.3c7e5310.chunk.js:1:115797

Also this message after some time:
Connection error
Connection failed with status 404, and response “”.

Issue in Edge with streamlit apps:

   WebsocketConnection WebSocket onerror

i @ main.3c7e5310.chunk.js:1

   Uncaught Error: Unsupported state transition.

at e.value (main.3c7e5310.chunk.js:1:114757)
at main.3c7e5310.chunk.js:1:117165

   Failed to load resource: the server responded with a status of 404 ()


   GET 404

Same problem on my phone with mobile data

I can use your app and many others without issues. There seems to be something preventing you from reaching the servers but the servers themselves are working.

Thanks for the info, not sure what caught the issue, first time that something like this is happening to me.
But if other users don’t have the issue it’s probably a personell problem.

Hi @saibot90 :wave:

Are you all still experiencing this issue? Or has it been resolved? If you’re still running into it, could you please share a link to a relevant app, what browser you’re using, and potentially a screenshot of the app in this error state?

@snehankekre not sure what caused the error but it works fine now

@snehankekre the problem now occurs again:

   WebSocket connection to 'wss://' failed: Error during WebSocket handshake: Unexpected response code: 502

The problem seems to occur just sometimes, but I’m not sure why:

Console log with edge:

   WebSocket connection to 'wss://' failed: Error during WebSocket handshake: Unexpected response code: 502

It seems like Streamlit can’t connect to the server. This happens to all my apps, no matter if i use edge, firefox, wifi, mobile internet etc.

This is one webapp which is not working currently:

But basically sometimes i can’t visit any streamlit app, it just shows PLease wait… and bunch of errors in the console log. Is there maybe a error in the streamlit server? Locally i can run all my Apps fine


I have the same problem for 2 days now, all my apps are very slow to load, sometimes I get the “Network issue” for no reason (and reloading page / removing cache doesn’t solve the problem). I have those issues when trying to visit other streamlit app too and other people have that problem too.

I also realized if i use a vpn to access any streamlit app the apps doesn’t load, the app just shows “Please Wait…”. This problem is new and i believe there must be a server issue in the background. Can someone from the streamlit staff look at this and please fix it? Thanks.


Same problem here, everything has been down all day… any news?

1 Like

Works for me, as well as other apps mentioned here.

same issue when I use VPN the app loads but the app doesn’t work in normal circumstances

Same here with me too. My 2 apps are not working showing connection timed out.

Today it started working well again, I made a commit at the end of the day and it started bugging again. I don’t know what is going on but it would be nice if we could get a fix or something

Any update on the issue? Yesterday I was able to access my Apps today they all show Please Wait… and connection error

The error seems related to this problem: New Streamlit Cloud apps no longer functioning · Issue #6155 · streamlit/streamlit · GitHub
The weird stuff is that not all users seems to experience this problem but some does

Your app is working right now as well as the one in the linked issue.

I am under the impression that many of the people experiencing these issues are located in Central Europe.

1 Like

Yes I’m located in Germany

Same here, also located in Germany. Issue started since yesterday for me.