App Not Deploying with requirements file


My app is not deploying.

Steps to reproduce

This is the log.

[14:37:01] πŸ™ Pulling code changes from Github...
[14:37:02] πŸ“¦ Processing dependencies...
[14:37:02] πŸ“¦ Processed dependencies!
[14:37:04] πŸ”„ Updated app!

If applicable, please provide the steps we should take to reproduce the error or specified behavior.

Expected behavior:

I expected the app to deploy.

Actual behavior:

I got an error installing requirements. Previously, I added a requirements file and I got the same error and then I removed it. I still have the same error.

Debug info

  • Streamlit version: 1.12.0
  • Python version: 3.9.7
  • Using Conda?
  • OS version: Windows
  • Browser version: Chrome

Requirements file


Additional information

If needed, add any other context about the problem here.

Remove gzip and pickletools from your requirements file and your python app.
These are no valid python packages and you don’t need them either.

1 Like

I did this and now my app is stuck on the Your app is in the oven for the last hour.