App not showing on dashboard

Hi everyone,

I’m new to Streamlit and I recently deployed my first app. I created the app from one of my GitHub repos. I included the link to the app in the readme.md file and it’s still working. However, the app doesn’t show up in my dashboard (see picture below)

This didn’t used to be the case and the app used to show up in the dashboard. Does anyone know how to fix this? I assume the easy way out is to delete the app and create it again, but it isn’t an efficient solution in the long run.

Best regards,

Alberto

1 Like

Hey @albertovidalrod! :wave:

The Cloud service is working fine now, so it’s worth giving it another shot. We may have had some temporary issues when you tried to deploy earlier.

Also try using a different browser or clear your browser cache. Sometimes that does the trick.

If none of that works, just let me know, and I’ll talk to the devs.

Thanks!
Charly

1 Like

Hi @Charly_Wargnier. Thanks for your reply.

For reference, I deployed the app on June 1st. I don’t know if the cloud was having problems back then.

I cleared the cache of the two browsers I typically use (Chrome and Vivaldi) and my dashboard doesn’t show the app in either browser.

I tried going to the app and then clicking on “View all apps” (see picture below) in the menu and again it doesn’t show the app in my dashboard. I find this very odd because the platform somehow knows it’s my app but it doesn’t show it.

Best regards,

Alberto

Thanks @albertovidalrod

Can you please send us the app URL?

Charly

@Charly_Wargnier the app url is: https://albertovidalrod-car-price-prediction.streamlit.app

Best regards,

Alberto

1 Like

@albertovidalrod are you logged in with the GitHub account that is an admin on the repository from which the app was deployed?

Thanks, @albertovidalrod!

I’ve forwarded this issue to our Devs.

If you’ve deleted and recreated the app, but it still doesn’t appear on your dashboard, it might be a bug! :bug:

Please note that it’s a bank holiday in the US today, so you may not receive any answers until tomorrow.

Thanks for your patience.

Best,
Charly

@Alexandru_Toader yeah, I’ve only logged in to Streamlit using my GitHub account. I tried signing out and signing in again, but it didn’t solve the problem.

@Charly_Wargnier Thanks for letting the Devs know.

I haven’t deleted the app, nor have I created a new one. I will probably create a new app this week (currently making changes to the code) and hopefully that one will stay. Thanks for all your help!

Best regards,

Alberto

1 Like

Please, help me with the same problem (don’t see it in my dashboard). The app URL is https://genldemo.streamlit.app/

Hi @alesan.med :wave:

The app is loading for me


Yes, it’s mine. But the problem is that I don’t see this application in my account’s dashboard

This happens to me sometimes. It may help to try an incognito window and you can also open the browser dev tools and turn off caching. This usually clears out issues for me and then the app magically starts working in a non-incognito window. There’s some weird stuff going on with Streamlit SSO and I can’t isolate the issue to explain or reliably reproduce it. It might be that I’m logged in under my GitHub account in some of my browser windows (in other apps) and with my Google ID in other windows (in different apps), and both IDs are used in my Streamlit account. The incognito window side-steps those snafus.

Glad its sorted, if its resolved close the thread

Hi,

I also have the same problem with the URL https://templarxddbotcorporation.streamlit.app, can you please help!

Thanks,
Putri

Hi! @alesan.med @asehmi @dachlia_putri I can look into this issue.

There is some server-side caching for the list of apps, so after changes are made on GitHub, it might take some time after permissions from GitHub are propagated to Streamlit Community Cloud, but it doesn’t look like this is the case.

I can take a look into this, but I would need some additional information. Feel free to DM me so that the information remains private.

The following would be super useful:

  • Link to the application
  • Email/GitHub ID you used to log in
  • Screen recording with the behavior (please also include the approximate time when this was recorded and the time zone so that I can correlate it with telemetry)