Application won't start after a long time

Hi, some time ago I uploaded my application to streamlit cloud, however if I want to run it now I get the following error? What is wrong?

────────────────────────────────────────────────────────────────────────────────────────
[14:41:49] 🖥 Provisioning machine...
[14:41:49] 🎛 Preparing system...
[14:41:49] ⛓ Spinning up manager process...
[14:42:18] 🚀 Starting up repository: 'premier_league', branch: 'main', main module: 'aplikacja.py'
[14:42:18] 🐙 Cloning repository...
[14:42:24] 🐙 Cloning into '/mount/src/premier_league'...

[14:42:24] 🐙 Cloned repository!
[14:42:24] 🐙 Pulling code changes from Github...
[14:42:25] 📦 Processing dependencies...

──────────────────────────────────────── pip ───────────────────────────────────────────

Collecting pandas==2.1.2
  Downloading pandas-2.1.2-cp39-cp39-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (12.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 12.3/12.3 MB 236.9 MB/s eta 0:00:00[2023-10-28 14:42:27.156944] 
Collecting pip==23.3.1
  Downloading pip-23.3.1-py3-none-any.whl (2.1 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 2.1/2.1 MB 256.2 MB/s eta 0:00:00[2023-10-28 14:42:27.275723] 
Collecting streamlit==1.28.0
  Downloading streamlit-1.28.0-py2.py3-none-any.whl (8.4 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 8.4/8.4 MB 191.4 MB/s eta 0:00:00[2023-10-28 14:42:27.431561] 
Collecting streamlit-option-menu==0.3.2
  Downloading streamlit_option_menu-0.3.2-py3-none-any.whl (712 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 712.3/712.3 KB 273.9 MB/s eta 0:00:00[2023-10-28 14:42:27.485945] 
Collecting plotly==5.14.1
  Downloading plotly-5.14.1-py2.py3-none-any.whl (15.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 15.3/15.3 MB 224.9 MB/s eta 0:00:00[2023-10-28 14:42:27.644206] 
Collecting category-encoders==2.5.1.post0
  Downloading category_encoders-2.5.1.post0-py2.py3-none-any.whl (72 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 72.4/72.4 KB 226.6 MB/s eta 0:00:00[2023-10-28 14:42:27.798543] 
Collecting ecos==2.0.12
  Downloading ecos-2.0.12-cp39-cp39-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (220 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 220.1/220.1 KB 256.4 MB/s eta 0:00:00[2023-10-28 14:42:27.857968] 
Collecting greenlet==1.1.3.post0
  Downloading greenlet-1.1.3.post0-cp39-cp39-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (154 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 154.4/154.4 KB 155.6 MB/s eta 0:00:00[2023-10-28 14:42:28.172036] 
Collecting osqp==0.6.2.post8
  Downloading osqp-0.6.2.post8-cp39-cp39-manylinux_2_5_x86_64.manylinux1_x86_64.manylinux_2_17_x86_64.manylinux2014_x86_64.whl (298 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 298.2/298.2 KB 245.0 MB/s eta 0:00:00[2023-10-28 14:42:28.303361] 
Collecting pytz-deprecation-shim==0.1.0.post0
  Downloading pytz_deprecation_shim-0.1.0.post0-py2.py3-none-any.whl (15 kB)
Collecting sklearn==0.0.post1
  Downloading sklearn-0.0.post1.tar.gz (3.6 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'error'
  error: subprocess-exited-with-error
  
  × python setup.py egg_info did not run successfully.
  │ exit code: 1
  ╰─> [18 lines of output]
      The 'sklearn' PyPI package is deprecated, use 'scikit-learn'
      rather than 'sklearn' for pip commands.
      
      Here is how to fix this error in the main use cases:
      - use 'pip install scikit-learn' rather than 'pip install sklearn'
      - replace 'sklearn' by 'scikit-learn' in your pip requirements files
        (requirements.txt, setup.py, setup.cfg, Pipfile, etc ...)
      - if the 'sklearn' package is used by one of your dependencies,
        it would be great if you take some time to track which package uses
        'sklearn' instead of 'scikit-learn' and report it to their issue tracker
      - as a last resort, set the environment variable
        SKLEARN_ALLOW_DEPRECATED_SKLEARN_PACKAGE_INSTALL=True to avoid this error
      
      More information is available at
      https://github.com/scikit-learn/sklearn-pypi-package
      
      If the previous advice does not cover your use case, feel free to report it at
      https://github.com/scikit-learn/sklearn-pypi-package/issues/new
      [end of output]
  
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.
WARNING: You are using pip version 22.0.3; however, version 23.3.1 is available.
You should consider upgrading via the '/home/adminuser/venv/bin/python -m pip install --upgrade pip' command.
Checking if Streamlit is installed

────────────────────────────────────────────────────────────────────────────────────────

[14:42:29] ❗️ installer returned a non-zero exit code
[14:42:29] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.`

The package name is wrong, as the error message says: