Can't access streamlit app from outside of network

Hi, I’ve made an app that I’m ready to share with a few friends. I forwarded ports and can access it from outside my network, but get stuck at the blue “Please wait…”. I’ve tried everything for Symptom #2 at this link: and I keep getting the same issue. On that same page, it explains how to set up a simple http server, which I did, and I can successfully see it from outside the network!

The page then says that the problem is in the streamlit config and to post on the forums, which is what I am doing. Please let me know if there’s any more information I can provide.

PS, when I try to start the streamlit server on port 80, I get an error: OSError [WinError 10013] An attempt was made to access a socket in a way forbidden by its access permissions

OK, mostly solved. I had tried everything above and when I checked the console was getting “websocket connection to ws:// failed. Websocket is closed before the connection is established” I hunted around and found this issue that I think is related:

I was accessing my external IP from on my network when I was getting that error. When I used my cell phone with no wifi to connect to the app, it worked.