Streamlit share apps stuck on "please wait'

Online Streamlit apps (including those on the gallery) all get stuck on “please wait” for computers within my company’s network. This was not occurring late last year.

I assume this is a problem with how something is set up at our end and I’d love to go armed to my IT department with a decent idea of why this might be occurring. Locally hosted apps still work on the computer hosting them.

Any suggestions?

Hey @jcadams,

I would assume there’s some type of firewall set up on your company’s network. I’d recommend talking to your company’s IT team to see if it’s possible to make the firewall less restrictive.

Hi. I’m facing this problem, too. I don’t see the ip address on the link.

Hey @Gyunald,

Unfortunately, stable outbound IP addresses is a feature that was rolled back due to Community Cloud transitioning to be a free community resource – more info on this is available here.

Hi, any idea why the “please wait” comes up for a while before loading the page in my multi-page app? There is no issue when accessing ec2 instance directly or running locally. Only when it is behind reverse proxy.

The issue is intermittent and doesn’t happen all the time. I’m using AWS load balancer as reverse proxy and HTTPS url for my streamlit application deployed on ec2 instance. The same page which loads up instantly can take a minute or two at times with “please wait” and web socket connection timed out issue. I tried all the methods in help section yet couldn’t fix it. I’m using streamlit 1.25.0 and Python 3.10 (tried with different versions).

If it was a firewall issue, I would assume it wouldn’t load even once. However, the issue seems to come up intermittently and the websocket connection upgrade would happen maybe after a minute or two. Since it is a multipage app with anchor tags, I believe the web socket connection upgrade request is sent for each pages when clicked.

1 Like

Hey did you ever solve this issue?

Hi, I was having similar issue. resolved by giving this custom command

python -m streamlit run --server.port 8000 --server.address --server.enableCORS=false --server.enableXsrfProtection=false

Disabling CORS worked for me but it was giving a warning that it is not compatible with XsrfProtection=true hence turned it off too. I am looking for its implications now.