Deployed app does not work (issue on a library)

Hello all,
I am new to streamlit. I have tried to deploy my speech recognition app. After deployment I am running on this error when I click on the link

I have tried figuring out what was causing the issues by trying to edit with Codespaces. I found that it is because of ffmpeg as you can see in the image below

So in the Codespaces, I tried installing it with sudo apt-get install ffmpeg. It works on the Codespaces. I no longer had the error. So I tried updating my .devcontainer json file by adding "postCreateCommand": "sudo apt update && sudo apt install -y ffmpeg" and rebooting the app but when cliciking on the link, I’m still getting the error.

I also tried adding ffmpeg on my requirements.txt but I am still facing the same issues

Can someone help on this topic please ?

Hey @BirdiD,

Thanks for sharing this question. Can you please share the link to your deployed app and your GitHub repo?

Hello @Caroline ,
Thanks for your reply. Here are the GitHub account and deployed app links:

  1. App : https://cawoylel.streamlit.app/
  2. Github : GitHub - cawoylel/windanam-streamlit: Streamlit app of Windanam ASR model

packages.txt

ffmpeg

@Franky1 I have tried this but still facing the same issue. I even created a new app from code spaces. I am getting this

Github for the new rep: GitHub - BirdiD/windanam-app
app : https://cawoylel-demo.streamlit.app/

I think it is probably a memory issue

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.