Error connecting with Github: "Huh. This isn’t supposed to happen."

I tried deploying my streamlit app using streamlit sharing, but when I attempted to connect my account with my GitHub account, I consistently encountered an error page displaying,
This isn’t supposed to happen.
Please contact support.”
I have verified that the email address associated with my streamlit account is the same as the one used for my GitHub account. I’ve also tried logging out of both my streamlit and GitHub accounts in my browser and then logging back in. Additionally, I attempted to clear my browser cache, and I even tried accessing from different devices and browsers, but the problem persists. Moreover, when I tried it on my mobile, an additional error message displayed, “Received no response from the server”. How can I resolve this issue?

Hi @Noledge0120, sorry to hear you’re facing this issue!

Please can you use the contact support link on the error page? This ensures it reaches the relevant people.


1 Like

Hi @Noledge0120

Additionally, can you also share the link to the GitHub repo of the app that you’re looking to deploy. Just wanted to make sure that the code does not have any bug that may cause this.


1 Like

The “Support” link on the page directed me to Snowflake’s official website, where I couldn’t find any section related to streamlit where I could submit my issue (Snowflake Community). The problem still persists.

This isn’t related to any specific repo; right now, I simply cannot connect to GitHub at all. Whenever I try to deploy a new app, I’m prompted to connect to GitHub. However, after I click on “connect to GitHub” and grant the necessary permissions, an error page pops up.

Thank you, @Noledge0120.

@Ted_Ricks Is this link meant to redirect to the Snowflake website?


This problem still exists. Every time I try to connect my streamlit user with my github user, it jumps to this error page. I’m sure my streamlit account and my github account use the same email. And because this page has no error message, I don’t know what happened.

This problem still exists. Any solution?