Error installing requirements

 ModuleNotFoundError: No module named 'pystan'
    ----------------------------------------
ERROR: Command errored out with exit status 1: /home/appuser/venv/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-70zgcl73/fbprophet_337725f21aac4a13963a82d91e787222/setup.py'"'"'; __file__='"'"'/tmp/pip-install-70zgcl73/fbprophet_337725f21aac4a13963a82d91e787222/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-f5x4y2_d/install-record.txt --single-version-externally-managed --compile --install-headers /home/appuser/venv/include/site/python3.7/fbprophet Check the logs for full command output.
WARNING: You are using pip version 21.0.1; however, version 21.1 is available.
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.
[manager] installer returned a non-zero exit code
[manager] Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

Hi @maansiii, Welcome to the community,

Could you please share a link to the repo?
Makes the troubleshooting easier.

Yeah sure.

Try adding pystan in your requirements.txt file and place it above fbprophet.

Same error again

Hi @maansiii

I just forked your repo you can check the changes on: https://share.streamlit.io/franciscoed/maansiii_stocks/

So, the first problem is the pystan version. On version 3 it requires to be imported as stan while fbprohet imports it as pystan (version 2), so the pystan version should be downgraded to 2.19.1.1

Not sure if all the packages needed to build are there on Streamlit Sharing environment, so I’ve added a packages.txt file, with the packages required by fbprophet.

Also, some changes on Readme in order to add the references.

Hope that helps.

Cheers

Good Evening Sir, thanks for helping, it worked out. Also yeah you don’t need packages.txt file.
Thank you Sir.

1 Like