Error when deploying public repos stored under Organization


I have a public repository containing a Streamlit app under an organization that I have created.

When I try to deploy it, I get the following error (also see screenshot attached below):

Mismatched workspace name and repository owner

Is that a bug? Is there any workaround for this?

Best regards,


1 Like

I have the solution.

To deploy an app owned by an organization, you’ll need to switch into that organization’s workspace by clicking your username in the top right corner – there should be a dropdown menu that appears and that displays the org name as an option. If the org doesn’t appear as an option in the dropdown, that means that your GitHub org admin has not granted access to Streamlit, in which case I would recommend reaching out to that person and requesting that they grant access.

Bold by me, that was exactly my case. I am the owner of the organization, so to grant access, I went to:

  • My organization’s profile > Settings > Third Party Access

This answer was by @Caroline Frasca from Streamlit Support. Many thanks to her and the team.

Best regards,

This was very helpful. Thanks Alberto and Caroline!
Posting what happened for me, in case it’s helpful to anyone else.

I did not have a pending request in my github organization’s profile, so I wasn’t sure how to grant access to Streamlit. However, after some digging, I realized that I did have a request within my own account.

My own profile > Settings > Applications > Authorized OAuth Apps > Streamlit

It turns out I had granted access to my account, but not yet for my organization. I granted access there and that fixed it!

1 Like