Deployment issue with admin permissions

Hi,

I’m trying to deploy a Streamlit app from a GitHub organization account. My status in the organization is Member, but the organization owner has given me admin rights in the repo that I’m trying to deploy from. However, when I try to deploy the app, I am shown the error message: ‘You do not have admin permissions on GitHub for this repository’.

In trying to solve this problem I have been looking at some other forum posts and trying to follow their suggestions (particularly this one). I have added a (empty) public repo to the GitHub organization account. I also make sure that I select the organization workspace at the top-right of the deployment screen. However, I still receive the error message.

Any suggestions on how to solve this issue would be much appreciated as we’re currently unsure of what else to try.

Thanks in advance,
Andrew

Hi @andrewpimm

Given that the admin rights was recently conferred after your login, could you try from scratch by revoking access to your GitHub account from the Streamlit Community Cloud and then add access to GitHub account again in order to start anew.

Please also see this excellent answer and step-by-step by @mathcatsand Unable to select organisation github repository for deployment - #19 by mathcatsand

Hopefully this works

Hi @dataprofessor , thanks for this. I’ve just tried revoking access to my GitHub account from the Streamlit Community Cloud (by clicking the ‘Disconnect’ button under ‘Source control’ in my Streamlit workspace settings) and then adding access again, and it didn’t work.

I also tried revoking access to Streamlit from my personal GitHub account and then logging into Streamlit and reauthorising, which I believe is the intention of @mathcatsand 's Option 2, and that also hasn’t worked. I am not an owner of our organization’s GitHub account, so can’t do Option 1 myself, but an owner granted access this morning.

Any other suggestions?
Andrew

The organization itself also needs to grant permission to Streamlit in order to deploy from repos in that organization. Only organization owners can grant this access as I’m aware. When following the steps to revoke access to your account on GitHub and sign back in, do you see the Organization listed at the bottom of the authorization? You should be able to “Request” access be granted so the owner can respond through GitHub.

Docs for organization access

Hi,

When signing back in after revoking access in my personal GitHub account, I see the organization listed at the bottom of the authorization with a green tick next to it, under the heading Organization access (see images below), as I already requested that access be granted and had this accepted by the organization owner. However, as mentioned above, revoking access and then adding access again didn’t seem to help.


I feel like I’ve tried everything I can think of or have found in forums and the Streamlit documentation, short of deleting my Streamlit Community Cloud account, and have had to make do by getting my colleague (the GitHub organization owner) to deploy the app himself.

Hmmm. You definitely should be able to deploy if you are an admin of the repo and a member of the organization. I recommend opening a support ticket to try and track this down specifically.