Error when using the Streamlit app on a different PC

I have deployed the card validity checker app, which works perfectly well for me. But when another user access this app from their Chrome browser (they have also tried it on Windows, MacOS and also Microsoft Edge), the app throws an error. Specifically, the downloaded files, when reuploaded to the App on a different page, throws an error instead of displaying the card validity.

Can someone tell me if this is a problem with Streamlit or if this is a problem with the way I have deployed, or written the program files, for example?

Here is my app:
Here is my GitHub Repo: GitHub - SheninFrancies/Streamlit-Apps: An UI-based approach to explore the exciting world of Computer Vision. Find the web applications that are deployed using Streamlit here.

Thank you.

Hey @Shenin_Francies,

Can you share the error message that you’re seeing?

I ran your app, downloaded the example picture and got this:
Credit Card 01
Which the app is unable to prcess. Compare it with the picture in the repo, which works as expected:
Credit Card 01_repo
I have no idea why this is happening. I forked your repo, deployed to Streamlit Cloud without making any changes and I could download the correct picture.

So you mean to say that this has something to do with the resize of the image in the download button or something as such?

Is there a possible workaround?

Also, I believe that I had changed the resize so that it doesn’t affect the downloaded image, soon after I posted my question here. I believe that is the reason why you received the image as it originally is?

I haven’t a clue as to why this happens for others. It works on my browser but when my colleagues use the App, they face the same problem that you have mentioned.

All I know is that when I use your application, the downloaded images do not match the ones in the repository. Actually they match the displayed (resized) images. I don’t know why that happens.

Looking at the code I don’t think it should happen. When I deploy your application it doesn’t happen. But when I run your application it does happen, I have no idea why.

So what did you do? The issue seems fixed now.

The issue was with the resize of the display_image.
I resized the image for display but passed the actual image dimensions for download button and it worked. Intuitively it made sense. I also took down the App and redeployed it. So maybe that has something to do with it as well?

I guess you’d know it better than me. Thank you anyway!