For any python file , browser opend by streamlit code showes nothing, it's just empty


I am new to streamlit. I have tried a simple file to write few lines in the browser. No matter whatever i write in the code file, the browser comes up with an empty page. I searched google it says there may be some confliction. Can any one guide how to resolve it?
python version i am using is 3.9
browser is microsoft edge
streamlit version is 1.27.2

code img

browser img

Steps to reproduce

Code snippet:

import streamlit as st

st.title(“Hamlet said…”)


To be, or not to be, that is the question:

Whether 'tis nobler in the mind to suffer

The slings and arrows of outrageous fortune,

Or to take arms against a sea of troubles

And by opposing end them.


If applicable, please provide the steps we should take to reproduce the error or specified behavior.

**Expected behavior:**
A new tab should be opend with default browser
Browser should show the data its told to write

**Actual behavior:**

A new tab is opend with default browser
'but it is showin nothing. its just an empty page

### Debug info

- Streamlit version: 1.27.2
- Python version: 3.9.18
- Using Conda
- OS version: windows 10
- Browser version: microsoft edge

### Requirements file


### Links

* Link to your GitHub repo:
* Link to your deployed app:

### Additional information

If needed, add any other context about the problem here.

Hi @Atya_Shakir

The Streamlit and Python versions that you are using seems to be compatible. Have you tried with another browser such as Chrome or Firefox and does the same issue still shows?

Also have you tried using other code such as

import streamlit as st
st.write('Hello world!')

This might be a silly note, but it appears that you have unsaved changes to – could you make sure it is saved? If you save it, you should get a notice in the browser that asks if you want to rerun the app with the new code.

1 Like

Thanyou so much dataprofessor,
Yes the problem was browser related. It worked perfectly on firefox,
Thanks again.

thank you, The issue was related to browser. things worked perfectly in firefox. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.