How can I turn off the "Welcome to Streamlit" Command Line Prompt?


I am looking to deploy a streamlit app from a docker container and with my system, I don’t have access to the command line when the app is deployed. Basically, I want a way to bypass the “Welcome to Streamlit” message that runs when I run the “streamlit run” command.

I see in the past that this was possible using the config.toml file with the following configuration:


But now, I can’t seem to find that option anywhere.

Any information would be greatly appreciated – and if there is a way to do this, it would be great if it was more clearly laid out in the documentation. Thank you!

This should do in Linux and probably MacOS.

streamlit run > dev/null

In a windows command prompt use NUL instead of dev/null.

But I don’t see the point. How is the message causing any inconvenience?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.