How to access the terminal for an app deployed on Streamlit?

Hi,

I’m a beginner, but am having trouble accessing the terminal in Streamlit. I want to edit the policy.xml file of a package that’s installed on Streamlit. How might I do this if it’s possible?

Apologies if this question seems simple but I’ve spent more than a day trying to figure this out.

Hi @Bart_Eshwar

I don’t think it is possible to get terminal root access with a deployed app on Community Cloud. However, you might want to fork a copy of the package (if available on GitHub) then edit the file. Afterwards you can install the custom package via requirements.txt by following instructions from the Knowledge base article

Hope this helps!

Best regards,
Chanin

1 Like

Hi Chanin,

Thanks so much for your reply. This seems like a great idea. I did what you’d suggested – I created a fork of the repository, changed the file, and then tried installing like the article you’d linked had said. However I got this error:

ERROR: git+https://github.com/barteshwar/ImageMagick (from -r /app/headerfootereditor2/requirements.txt (line 3)) does not appear to be a Python project: neither ‘setup.py’ nor ‘pyproject.toml’ found.

I’ll give you some background. The “package” I’m trying to install is called ImageMagick, which is a dependency for the moviepy python package. ImageMagick isn’t a python package, and thus far I’d been putting it in packages.txt instead of requirements.txt. Would you know how I could get my forked version of ImageMagick to work? I tried adding the same command in packages.txt but that didn’t seem to work.

Thanks so much for your help!

Did you got to solve this issue?