How to stop Magiccommand

When writing code magic command automatically displays dataframe. Problem is when you are importing credentials they should not be on the streamlit output page. So how to disable magic command and show only relevant information

Iā€™m not sure, but can you try this?

get_ipython().run_line_magic('load_ext', 'watermark')

or this

streamlit run app.py --no-echo

You can turn magic commands off in the config file.

[runner]
magicEnabled = false
1 Like