I can't delete my own App

Hello,

I tried to delete my app but I can’t click on Delete option, and I get this message

“You have view-only access to this application”

This seems to be a bug, since I am the creator of the application, so I should have the permissions to delete it.

Note : the corresponding repository of this app is deleted for now, this may have something to do with the problem.

Best Regards

1 Like

Hi @Abdelgha_4,

Welcome to the community, and thank you for reporting this.

I have to say this is not something I’ve encountered before. I’ve liaised with our Devs so hopefully, we should be able to feedback shortly.

Best,
Charly

Hi @Abdelgha_4

I’ve had Devs telling me that the deleted repo was most certainly the issue here.

Would it be possible for you to recreate the repo to check if this is indeed the cause?

Best,
Charly

It worked, I temporarily created a repository in GitHub with the original name of the repo I deleted. Then I was able to delete the app in the Streamlit Cloud dashboard.

Thank you !