I understand this issue has been resolved previously but it seems I can't deploy my app on streamlit sharing

I am currently getting the Server error [A10]: Unable to create app error when trying to deploy my app. The previous answers did not suggest any action on my end to solve this problem. Would appreciate any suggestions.

Thank you

Hello @Rushmore,

Could you share a link to the Github repository of your application, so we can fork it and test on our side? That will make debugging a bit easier :slight_smile:

Have a nice day,


Apologies, this has been attached:

Thank you

Hello @Rushmore @andfanilo

I forked your repo and tried to run the application. It really works fine for me.
I just installed all the necessary requirements and ran the command streamlit run SOCVEST app.py

PFA screenshots:

Home Page

Data Exploration

I guess some of them have also faced this issue previously and as mentioned by @Marisa_Smith they got it fixed and it was resolved after re-deployment.
Link - My deployed app got deleted and Server Error [A10]

Thank you and please ask in case of doubts!


That is crazy cos I just tried it and its still giving me this error.

1 Like

The picture shows the error I am receiving.

Hey @Rushmore,

Can you send me the email that’s associated with your account? I think that this is an error in our database system and I want to check out your account. See if we can get it fixed on this side!


Thanks for responding. This is the email:


I have sent this on to the team and will get back to you when i know more!

Thank you!

1 Like

Hey @Rushmore,

So it turns out there were a couple of issues with your repo causing this:

  • Requirements.txt, must be lower case (change it to requirements.txt)
  • the main app file SOCVEST app.py has a space in the title. Generally, you can’t use spaces in coding file names (this can cause unexpected errors). We are now working on an update that will be able to take file names with spaces, but for now, I would recommend removing the space or adding an underscore to your title (SOCVEST_app.py)
  • The engineering team also let me know that there are some problems with the dependency versions (they didn’t go into specifics) but if you remove all of the version specifiers from your requirements then you will be good to go!

Happy Streamlit-ing!

1 Like

Lovely jubly, it worked!

Thank you!

1 Like