Server error [A10]: Unable to create app via streamlit cloud

Dear Streamlit team,

I’m getting the error above for my github repository (GitHub - woochan-hwang/GSTT-Transplant: Review of all renal transplants in GSTT 2009-2019) via Streamlit Share. I checked previous entries with similar issues but they all seem to have been fixed by the engineering team as far as I can tell. Could you help me with what the issue might be? It would also be great if we could get more detailed error messages.

Best,
Woochan

Hey @woochan-hwang,

Can you take a screenshot of your dashboard of when you encountered this error? That will help us debug what might be happening here.

Happy Streamlit-ing!
Marisa

Hi Marisa,

I’ve added the screenshot below.

Did you change your Github username recently? That’s caused issues before

Nope, it’s been the same for at least a year.

Hi all, I’ve fixed the issue! Bit embarrassing as it was a simple issue.

My streamlit_app.py file wasn’t in the root dir. When I run it locally I always ran ‘streamlit run streamlit_app.py’ from the dir where the app was but it broke when I tried running ‘streamlit run parent_dir/streamlit_app.py’ due to a path referencing issue for an image file I was using.

1 Like