In config, increase wait for components, or mute warning

Hi,
related to this topic i have a st app with components in gCloud (appEngine & cloudRun).

Very, very, sporadically, the infamous warning below appears. I hope with components v2 this will never happen anymore, with same speed for native & non-native widgets.

But meanwhile, in the config file
can i make st wait more for the components to load?
can i mute (or customize) the warning?

In a production app, for external clients, i would prefer an ommitting widget without warning, than current behaviour.

disclaim, this warning happens with almost every component: login, antd, option_menu, etc.

thanks

warning
292590910-07a45ed5-96c9-4ec9-9239-032a93997202

Your app is having trouble loading the streamlit_option_menu.option_menu component.
(The app is attempting to load the component from ****, and hasn't received its 'streamlit message.)
If this is a development build, have you started the dev server?
If this is a release build, have you compiled the frontend?
For more troubleshooting help, please see the Streamlit Component docs or visit our forums.
.```

Hi @iuiu

For the error message and traceback, you can turn this off by setting the showErrorDetails parameter to false

More info in the Docs:

Hope this helps!

showErrorDetails = False doesn’t disable the warning.
Also, doesn’t disable the error message neither. Just makes it a little shorter.

Hi @iuiu

Perhaps you can try using try/except for running the code and error handling.

More info here:

Hi @dataprofessor,
thanks for the response,
but as stated above, streamlit displays a st.warning.
Not a python warning, even less a python error raise.
So your solution does not fit.

My question is more in the streamlit developers side, on how to catch this st.warning as a warning or error. Or if not posible, at least, mute it

Hi @iuiu

Have you tried using small letters instead for F to f:

showErrorDetails = false