(The app is attempting to load the component from ****, and hasn't received its "streamlit:componentReady" message.)

while running streamlit application on ec2 getting this error, even upgrade the streamlit to 1.20.0 but still getting same error and this is error message:

Your app is having trouble loading the streamlit_option_menu.option_menu component.

(The app is attempting to load the component from ****, and hasn’t received its “streamlit:componentReady” message.)

  • If this is a development build, have you started the dev server?
  • If this is a release build, have you compiled the frontend?

Hey @Aakash_Kumar,

Thanks for sharing this question. Can you please update your post to include a code snippet/your requirements file so we can try to reproduce the error?

Hi, I am having exactly the same issue running streamlit 1.25.0
It only occurs when deployed on the cloud. Also, funny enough, when I run the App on Streamlit Cloud it is ok, but my App is quite power hungry, so I had to move it to Heroku. Over there it runs ok with the slowest Dyno (about the same speed as Streamlit Cloud), but as soon as I give the app more computing power - this error occurs. Any ideas how to handle this? The page of my App on Streamlit Cloud causing the issue is here: https://dungbeetleapp.streamlit.app/Material_Warehouse