Inbrowser codespaces demo timing out

Hi! So a few weeks ago I attempted to use github codespaces for a new app, and it turned out great! However, I am just retrying today and I’m encountering a timeout for the display screen as soon as the app loads after creation via “Create new app with GitHub Codespaces”:

I get the same result if I open in browser. Needless to say, I haven’t changed the launch command, it’s still

streamlit run --server.enableCORS false --server.enableXsrfProtection false

Neither the Internal nor external URLs are working. Just in case, I reset the “preview in editor”, to no avail. I tried changing the port in the devcontainer.json, but I don’t think the codespace contains a .streamlit/config.toml, so I actually can’t change the port.

Note, now the app that I originally created no longer works, showing same problem. What gives?

I tried on two ISPs, and tried rebooting the app just in case.

Oh, and the public version works correctly, it’s just the view inside VS Code that seems busted.

Any hints?

Hi @Amit_Kohli,

Thanks for posting!

Your app seems to be working now. For the codespaces time out, did you try restarting the container?

Yes, the app works perfectly… the problem was always the timeout. I actually tried a third ISP and it seems that’s the problem!! Incredible, I MUST switch to a new one.

1 Like

Hi @Amit_Kohli,

Glad it’s working! Happy Streamlit-ing! :balloon:

1 Like

I’m still having ISP issues and can’t switch due to IP filtering rules elsewhere… what can I do to make the github code spaces work by default on my faulty ISP? Is there anything I could try @tonykip?

Have you considered using a VPN? Your ISP might be blocking or throttling your traffic to GitHub Codespaces. You could also reach out to GitHub Support for more specialized help with Codepsaces.
I hope this helps.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.