Issue Accessing Streamlit: Unknown Error Code 403

Hello everyone,

I hope you’re all having a great day. I’ve been facing an issue that has been affecting my access to Streamlit for the past few days, and I haven’t been able to find a solution. I’m looking for some guidance or suggestions to resolve this problem.


I’ve tried various solutions on my own, such as clearing my browser cache and trying different browsers, but none of these actions have succeeded in resolving the issue.

I would greatly appreciate any help or advice you can offer to troubleshoot this error.


Are you deploying a public or private app? There’s a limit of 1 private app for deploying apps to the Streamlit Community Cloud (ERROR : 403 deploy error - #6 by Melo04).

In that case, could you try deleting a previously deployed private app and try again. Or setting the GitHub repo to be public and try deploying again.

Hope this helps!


It appears that you are trying to deploy an app and are unauthorized to do so, given the 403 error.

Each user is given 1 private app to deploy on the Streamlit private cloud but UNLIMITED apps on the Community Cloud.

Try deploying the app as a public app on the community cloud.

Let’s see if it’ll work.

Best, Jyo

Hello, I am very new to streamlit and experiencing the same issue. I do not understand how I can delete the app and deploy it as a public one when I am not able to even sign in. Any help?

Hi @SofiaN-t,

Sorry for the confusion – please disregard the answers above. If you see a 403 error when you log in, please open a support ticket by following the process outlined here – our support team can resolve this for you.

Hi @Caroline

I’m facing the same issue 403 2 minutes after deploying the app. I tried to follow your suggestion but it’s not working, I’m getting a captcha error when I try to create a snowflake account. I sent an email to and I’m not getting a response. Could you help me with this please?

Hi @Davidmerge, can you DM me your GitHub username?

Hello @Caroline, I’m new to this community and I couldn’t locate the DM option. I ended up reaching out to you via LinkedIn.

Responded on LinkedIn :slight_smile: