Issue with bs4 dependency


I trying to run my app on streamlit but I am constantly running into this error
E: Unable to locate package bs4

Here is my git hub repo: (

What am I doing wrong here?

I saw that you had bs4 in both your packages.txt and requirements.txt. I think that is the biggest reason that caused the problem. Streamlit documentation said " Only include packages in your requirements file that are not distributed with a standard Python installation. If any of the modules from base Python are included in the requirements file, you will get an error when you try to deploy."


just a side note, you can try to indicate the versions of dependencies you’re using. e.g. bs4==0.0.1 Also I noticed you added numpy and pandas, I think they are already in streamlit, so no need to mention them in requirements.

I tried doing that but still gives the same error.

Typo: requiements.txt

Thank you. That worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.