Module install error while deploying to cloud

I’m trying to host my app on Streamlit cloud, and am running into an error installing a dependency.

It won’t let me upload my log file, so here is a screenshot of the log instead.


(I have updated my pip installation, with the same error occurring)

I’m not quite sure if my app is even using ‘cython’ or ‘planarity’ in any capacity. Maybe these are dependencies of modules I am using.

Any help would be greatly appreciated.

Hi @prxsto, welcome to the community! :wave: :partying_face:

Here are COMPAS’ official installation instructions for PyPI:

pip install cython --install-option="--no-cython-compile"
pip install compas

Including the above in your requirements.txt will still throw Cython build errors:

cython --install-option="--no-cython-compile"
compas

What worked for me was using COMPAS’ recommended installation with conda:

To do so, delete requirements.txt, and create a new environment.yml file containing the following:

name: research
channels:
  - conda-forge
dependencies:
  - compas

The above will take a few minutes to install compas and its dependencies, but it should successfully install nonetheless. Let me know if you run into issues with the conda method.

Best, :balloon:
Snehan

2 Likes

That’s gotten me past that problem but now it’s failing to install Plotly- giving a classic “no module found” error. Can I add Plotly to the dependencies of the yml file to force installation of it?