ModuleNotFoundError: No module named 'gekko'

Hello there!

I wanted to deploy my app, It already is in GitHub and It has the requeriments.txt file but an error keeps showing, how can I fix it?

The app runs perfectly on my local machine in the python env.

I hope you could help with this!

Hi @alfonsoamt, welcome to the community,

I forked your repo and tried to run it on streamlit share. Noticed that no packages were being installed during the app initialization. There is typo in your requirements.txt file name.

Is now: requeriments.txt
should be: requirements.txt

That being said, I’m afraid I ran into another error when trying to deploy.
pywin32 is a requirement of you app, which is not available on streamlit share since it runs on Linux.

ERROR: Could not find a version that satisfies the requirement pywin32==301 (from versions: none)
ERROR: No matching distribution found for pywin32==301

removing pywin32==301 and pywinpty==1.1.3 from your requirements.txt fixes this.



That typo! I thank you so much! this fixed the problem! :sob:

1 Like