My app doesn't open in iOS when using the latest version of streamlit

Hello everyone! I have tried building my first app in deploying it into the StreamLit Cloud. The process is very simple and straightforward. But I can’t get my app to work on an iphone. I just get a blank screen. Everything works fine from a Windows client.

I have tried a few things:

  • Added port=8501 the .streamlit/config.toml file as per Blank screen on ios devices.
  • Tried disabling CORS and Xsrf protection.
  • Forked some sample apps from the gallery. The original app is working (even with iOS). When I deploy from my fork then it only works from a Windows client, but not from iOS.

UPDATE:
Eventually I managed to get it working by downgrading to strealit==1.6 using the requirements.txt file. Not ideal.

I am curious if this is a known issue or if I am doing something wrong.

1 Like

Same issue here… Here is my app but it doesn’t load on IOS (MAC or iPhone), it just shows a blank screen.

https://share.streamlit.io/viniciusgribas/analise_dados_geracao_br/main/Analise_Geracao_II/Py/Dashboard_Geracao_Brasil_app.py

2 Likes

I have the same problem, for a selfhosted app on a Raspberry. Likewise, I included port=8501 in the .streamlit/config.toml file .

Still no update on this issue?

Still no update on this issue? Looks like a big bug to me, same problem here.
Added port 8501 but changes nothing.

Saw this open issue on GitHub:

1 Like

Hi @Guilherme_Hungaro and @ayansengupta17

If you feel strongly about the issue, please upvote the issue on GitHub and comment your support for it, with additional details about your app (link, repo, etc). Please refrain from tagging the Streamlit team here.

downgrading to streamlit ==1.6 worked for me aswell. Thank you!

1 Like