"Please wait..." forever error when deployed on GitHub

I deployed an app directly from the GitHub repo using https://share.streamlit.io/

The app initially worked, but with no changes to the code whatsoever, it now stopped working. I’m seeing the “Please wait…” message forever.

This article doesn’t help me much because it mentions a bunch of settings that I haven’t even done when deploying, I just followed the instructions as per https://share.streamlit.io/

How can I fix this issue? Do I change anything in GitHub?

Hi @Chain, and welcome to the Streamlit community! :balloon::raised_hands:

I’ve got an error:

Do you know what the logtrace says?

Thanks,
Charly

Hmm you might have just selected some parameter that gives no results.

But the point is, it actually loads now!!..

This is really odd. Is there some hosting reliability issue on streamlit side?

1 Like

Happy to hear your app is now working! :slight_smile:

Happy streamlit-ing! :balloon:
Charly

Thanks. I guess I’m worried that it will happen again.

Can I trust that it’ll keep working?

Just when I wrote this, I now see that the app isn’t working once again :((

I have very few package dependencies which are all loading, the app works fine on local, and it also worked fine on streamlit just yesterday.

Why is this happening? Is there a hosting issue on Streamlit side?

Hi @Chain

Which message do you get in the log trace?

Charly

How can I check the log trace?

You’ll see the error trace if you click at the bottom right of your streamlit app.

Best,
Charly

I faced this too, seems to be related to streamlit’s websocket timeout being too low