Private app loads indefinitely for some users


Big Streamlit fan here and have been absolutely loving it for the past few years.

Just ran into a little snag this week with our main private app:

In short, we have a private app shared with about 40-50 employees. But for some odd reason, some users can access it just fine whereas for other users it just loads indefinitely like this:


Any suggestions on how to fix the issue? We’ve tried using different browsers, VPNs, etc and it’s still unpredictable when it will work and when it will load indefinitely. We also tried rebooting the app but still experienced the same issues.

Any help is greatly appreciated!


Hello all - we are also facing this issue. The private app is not working, just spinning, but public apps seem to be working fine. Cycling the private app to public and back to private does seem to restore functionality temporarily fyi @Jeff_Oxford , but it’s impossible to predict when the service goes down and it is disruptive to all users.

I’m having the same problem and it’s really bothering me because it’s unthinkable for me to play the app in public. Are there any other solutions?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.