Streamlit 1.5 won't run at all

was running 1.3 fine,( OSX 11.6.3, Python 3.9) now on 1.5 and it won’t even launch . Tried it in a new virtualenv and still not working. Tried it without virtual env and still the error.

‘streamlit hello’ just gives:

streamlit hello
Traceback (most recent call last):
  File "/usr/local/bin/streamlit", line 8, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.9/site-packages/click/core.py", line 829, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python3.9/site-packages/click/core.py", line 782, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python3.9/site-packages/click/core.py", line 1259, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python3.9/site-packages/click/core.py", line 1066, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python3.9/site-packages/click/core.py", line 610, in invoke
    return callback(*args, **kwargs)
  File "/usr/local/lib/python3.9/site-packages/streamlit/cli.py", line 154, in main_hello
    bootstrap.load_config_options(flag_options=kwargs)
  File "/usr/local/lib/python3.9/site-packages/streamlit/bootstrap.py", line 318, in load_config_options
    config.get_config_options(force_reparse=True, options_from_flags=options_from_flags)
  File "/usr/local/lib/python3.9/site-packages/streamlit/config.py", line 1006, in get_config_options
    _update_config_with_toml(file_contents, filename)
  File "/usr/local/lib/python3.9/site-packages/streamlit/config.py", line 888, in _update_config_with_toml
    _set_option(f"{section}.{name}", value, where_defined)
  File "/usr/local/lib/python3.9/site-packages/streamlit/config.py", line 865, in _set_option
    assert key in _config_options, f'Key "{key}" is not defined.'
AssertionError: Key "s3.keyPrefix" is not defined.

Hi @steeley :wave:

I suspect the error is caused by an outdated entry in your config.toml file. Do you have a global config file located at ~/.streamlit/config.toml or a project config file at $CWD/.streamlit/config.toml , where $CWD is the folder you’re running Streamlit from?

If so, deleting the file will likely fix your issue. All config options related to s3 were removed in v1.4.0.

Best, :balloon:
Snehan

thanks - it was that…
I’m sure this is going to trip others up so hopefully it will get documented somewhere in the install notes.

1 Like

I agree actually. Even I ran into this issue and I got confused for a bit.

Thanks for the feedback, @steeley @willhuang! I’ll create a Knowledge base article about it and update you both when it’s live.

1 Like

I dont think you have to remove the whole file. If the below line is just commented out it works fine.
The config.toml file contains project level configurations and it may not be correct to remove it.

#keyPrefix = “”

1 Like

It is not. I deleted tne config.toml, no joy. There was nothing related to s3. Only reverting to 1.4 helped.