Streamlit Azure Web App VNET Skeleton Loading

Hi All - seeking some help after striking out across the board. I am trying to deploy a barebones app to an Azure Web App (linux) (not container - although I have also tried docker with the same result). I am getting an error that I have seen other places online- streamlit just renders over & over again and displays the following error:

I am not using nginx. I have tried numerous configuration possibilities in .streamlit/config.toml - however based on other forums the below seems to be a minimum working example

[server]
port = 80
enableXsrfProtection = false
enableWebsocketCompression = false
headless = true

Have also set the serverAddress to 0.0.0.0 as well as the domain name of our App. Neither worked. I configured Azure environment variables to both look at port 80 (WEBSITES_PORT / PORT).

The gist of the question is - has anyone else run into these struggles in their corporate environment where they are using a VNET/Subnet setup? Did you end up solving your issue?

One follow on point - I was successfully able to deploy the application to azure on my personal machine where i set up a free azure subscription for testing purposes.